CentOS7修复内核CVE-2021-27363/27364/27365漏洞

CVE-2021-27363、CVE-2021-27364 和 CVE-2021-27365 存在于内核的 iSCSI 模块中。虽然在默认情况下该模块是没有被加载的,但是 Linux 内核对模块按需加载的支持意味着它可以很容易地被调用到行动中。安全专家在 Red Hat 所有已测试版本和其他发行版本中均存在这些漏洞,属于 Linux 内核中的提权漏洞,可让攻击者轻松获得 root 权限,在 Linux 内核中已存在 15 年。

Linux 内核属于 5.11.4、5.10.21、5.4.103、4.19.179、4.14.224、4.9.260、4.4.260 或以上版本,已修复了这些漏洞。

升级办法:

[root@ecs-Sebnt ~]# rpm -Uvh http://elrepo.srv.magticom.ge/archive/kernel/el7/x86_64/RPMS/kernel-ml-5.12.8-1.el7.elrepo.x86_64.rpm

安装过程会出现以下日志信息:

[root@ecs-Sebnt ~]# rpm -Uvh http://elrepo.srv.magticom.ge/archive/kernel/el7/x86_64/RPMS/kernel-ml-5.12.8-1.el7.elrepo.x86_64.rpm
获取http://elrepo.srv.magticom.ge/archive/kernel/el7/x86_64/RPMS/kernel-ml-5.12.8-1.el7.elrepo.x86_64.rpm
警告:/var/tmp/rpm-tmp.F7O8Zj: 头V4 DSA/SHA1 Signature, 密钥 ID baadae52: NOKEY
准备中...                          ################################# [100%]
正在升级/安装...
1:kernel-ml-5.12.8-1.el7.elrepo    ################################# [100%]

升级后,我们需要将此内核设置为默认内核:

[root@ecs-Sebnt ~]# grub2-set-default 'CentOS Linux (kernel-ml-5.12.8-1.el7) 7 (Core)'

重启机器,即可升级到最新内核:

[root@ecs-Sebnt ~]# uname -r
5.12.8-1.el7.elrepo.x86_64

注意:如果升级失败,可以开机时候选择原内核启动,将新安装的内核卸载即可。

» 本文链接:CentOS7修复内核CVE-2021-27363/27364/27365漏洞
» 转载请注明来源:刺客博客
» 如果文章失效或者安装失败,请留言进行反馈。
全部为采集文章,文中的 联系方式 均不是 本人 的!

发表评论